Ubuntu Edgy nl

From

Revision as of 10:43, 8 October 2009 by Krampo (Talk | contribs)
(diff) ← Older revision | Current revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Image:Ubuntuguide_logo.png

Onofficiele Ubuntu 6.10 (Edgy Eft) beginnersgids

Omdat Ubuntu 6.10 (Edgy Eft) net is vrijgegeven, is deze gids nog in aanbouw. Jouw hulp bij testen en het perfectioneren van deze gids is van harte welkom

Deze gids is gestart door Chua Wen Kiat (Kuala Lumpur, Malaysia). Het wordt nu onderhouden door het Linux Center van Universiteit van Latvia, en iedereen die wilt bijdragen.

Men kan disscussieren over deze gids op het officiele UbuntuGuide.org Forum op ubuntuforums.org. Stap even langs en start discussieren.

Jammer genoeg, door wiki-vandalisme, enkel geregistreerde gebruikers kunnen deze wiki aanpassen, en enkel geregistreerde gebruikers kunnen je een account aanmaken. Wanneer je wenst om te helpen, laat het ons weten. We willen een account aanmaken. [ ubuntuguide -at- ubuntuguide.org ] Vergeet niet te zeggen welke gebruikersnaam dat je wil gebruiken en waarom je het nodig hebt (wat wil je bijvoorbeeld veranderen aan de gids).


MikrobartOrvilsQuashJiyuu0CargoGabemorrBytecopekrampoSimosStubbyeljacoshaiThunderMHasileadammichaelroachBelisarivsCheatorHankTamalKaotikssoniahKutanMehdirichuxShadymanHavarillfr0zen_penguinLouisShadymanshanlot751EtienneRabid9797Mantas Smelevičiusperspectoffphloseadogsmalugo2debugPakosRedBassCyberAngelCogeeldineroycorreAlgimantasBucinskasUficAntidrugueVahidLouis KingRsinghBorut-TCinglallsTownrayANtuMaLaMpete alleboneGreenstarThe TurkRonBCompotatojoMbrasigma80EnlightenedswineKarthikeyanemorrp1Th0rv4ldjspanglerSevoirForainand other friends of our community edit



Oudere versies


Complete lijst van alle subpaginas Ubuntu:EdgyNL/TOC


Contents


Ubuntu:EdgyNL/AlgemeneOpmerkingen

Ubuntu:EdgyNL/SnelBeginnen

Softwarekanalen

Hoe kan ik extra softwarekanalen toevoegen

sudo cp -p /etc/apt/sources.list /etc/apt/sources.list_backup
sudo gedit /etc/apt/sources.list
  • Vervang alles met de volgende regels
Om je lokale mirror te gebruiken, kan je "cc." toevoegen voor archive.ubuntu.com (cc = jouw landcode)
b.v. deb http://lv.archive.ubuntu.com/ubuntu edgy main restricted universe multiverse
## Add comments (##) in front of any line to remove it from being checked.   
## Use the following sources.list at your own risk.  

deb http://archive.ubuntu.com/ubuntu edgy main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu edgy main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu edgy-proposed main restricted universe multiverse

## MAJOR BUG FIX UPDATES produced after the final release
deb http://archive.ubuntu.com/ubuntu edgy-updates main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu edgy-updates main restricted universe multiverse

## UBUNTU SECURITY UPDATES
deb http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse

## BACKPORTS REPOSITORY (Unsupported.  May contain illegal packages.  Use at own risk.)
deb http://archive.ubuntu.com/ubuntu edgy-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu edgy-backports main restricted universe multiverse

## PLF REPOSITORY (Unsupported.  May contain illegal packages.  Use at own risk.)
deb http://packages.freecontrib.org/plf edgy-plf free non-free
deb-src http://packages.freecontrib.org/plf edgy-plf free non-free                                               
                                                                                                                                         
## CANONICAL COMMERCIAL REPOSITORY (Hosted op Canonical servers, not Ubuntu
## servers. RealPlayer10, Opera, DesktopSecure en more to come.) 
#deb http://archive.canonical.com/ubuntu edgy-commercial main

## Listen
#deb http://theli.free.fr/packages/ edgy listen
  • Bewaar het bewerkte bestand
wget http://packages.freecontrib.org/ubuntu/plf/12B83718.gpg -O- | sudo apt-key add -
sudo apt-get update
  • Je mag ook je sources.list vervangen met deze bijna complete lijst: sources.list Use at own risk.
  • Bewerk de standaard Ubuntu sources.list enkel wanneer je weet wat je doet. Repos mengen kan schade berokkenen.

Ubuntu:EdgyNL/UbuntuUpdates

Add-On Applicaties

Hoe Easy Ubuntu gebruiken

  • Lees #Algemene Opmerkingen
  • Easy Ubuntu is een kleine recht-vooruit tool dat nieuwe gebruikers toelaat om gemakkelijk een wijde varieteit van inhoud te installeren voor Ubuntu zoals media codecs, lettertypes, Macromedia Flash en Sun Java.

Open een terminal via Menu -> Accessories -> Terminal en volg de volgende commands

wget http://easyubuntu.freecontrib.org/files/easyubuntu-3.023.tar.gz
tar -zxf easyubuntu-3.023.tar.gz
cd easyubuntu
cp packagelist-dapper.pot packagelist-edgy.pot
cp packagelist-dapper.xml packagelist-edgy.xml
sudo python easyubuntu.in
  • Van het Easy Ubuntu venster, duid de juiste boxen aan om inhoud te downloaden en te installeren naar Ubuntu.
  • Noot: Gebruikers van de vorige EasyUbuntu 3.0 versie kunnen problemen ervaren met het installeren van Flash en Java.
  • Als je een automatische update verkiest, volg dan deze instructies:

afhankelijk van welke versie je gebruikt:

Op Ubuntu:

sudo gedit /etc/apt/sources.list

Op Kubuntu:

sudo kate /etc/apt/sources.list

In je text-bewerker dat zal geopend worden, voeg op het einde van je /etc/apt/sources.list bestand dit toe:

deb http://easyubuntu.cafuego.net main easyubuntu

Vanaf nu verder, zal EasyUbuntu nu automatisch geupdate worden.

Hoe kan ik Automatix op Ubuntu, Kubuntu, en Xubuntu installeren

  • Lees #Algemene Opmerkingen
  • Automatix is een graphical interface voor automating the installation of the most commonly requested applications in Ubuntu/Kubuntu/Xubuntu linux.
  • Noot: Voor installatie, please note that certain codecs it provides may be prohibited in certain countries. You are responsible voor ensuring those laws are not broken.
  • using your favorite text editor (kwrite, gedit)
  • gebruik je favoriete tekst editor (kwrite, gedit)
sudo kwrite /etc/apt/sources.list
  • Haal het hekje weg bij de volgende regels
#deb http://archive.ubuntu.com/ubuntu edgy main
#deb-src http://archive.ubuntu.com/ubuntu edgy main
  • Als je Ubuntu of Xubuntu Dapper gebruikt, voeg de volgende regel toe aan het eind van het bestand.
deb http://www.getautomatix.com/apt/ edgy main
  • Sla het bestand op en sluit het
  • Voeg GPG sleutel toe
wget http://www.getautomatix.com/apt/key.gpg.asc
gpg --import key.gpg.asc
gpg --export --armor 521A9C7C | sudo apt-key add -

  • Typ de volgende commando's om Automatix te installeren
sudo apt-get update
sudo apt-get install automatix2

  • Automatix kan nu worden gestart via het Menu
Menu -> Systeem -> Automatix
  • Het kan als volgt worden gestart via de opdrachtregel
automatix2

Hoe kan ik J2SE Runtime Environment (JRE) met Plug-in voor Mozilla Firefox installeren

Noot: Programma ingevoegd in Automatix2. Indien je Automatix2 gebruikt, dit programma kan al geinstalleerd zijn.

sudo apt-get install sun-java5-jre sun-java5-plugin
  • Wanneer ernaar wordt gevraagd, accepteer de DLJ licencievoorwaarden.
  • Om J2SE in te stellen als de standaard JVM (benodigd voor programma's als Frostwire, RSSOwl en als een plugin voor Mozilla Firefox):
sudo update-alternatives --config java

Kies dan de mogelijkheid die hoort bij J2SE (meestal de 3e optie).

Hoe kan ik JRE v5.0 Update 9 installeren

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

Choose "Java Runtime Environment (JRE) 5.0 Update 9" en klik op "Download"
Accept License Agreement 
Download the "Linux self-extracting file"
  • Install the required tool :
sudo apt-get install java-package
  • Create the Ubuntu package :
fakeroot make-jpkg jre-1_5_0_09-linux-i586.bin
  • Install the resulting package :
sudo dpkg -i sun-j2re1.5_1.5.0+update09_i386.deb


  • Restart Mozilla Firefox
  • If you get an error, try changing the 09's in the filenames to the appropriate version number.

Hoe kan ik Java Development Kit (JDK) v5.0 installeren

sudo apt-get install sun-java5-jdk
  • Accept the licence agreement that appears.
  • Set Sun's JVM as default Java version:
sudo update-java-alternatives -s java-1.5.0-sun
  • Edit /etc/jvm en move /usr/lib/jvm/java-1.5.0-sun to the top of JVMs offered:
gksudo gedit /etc/jvm

Hoe kan ik Flash Player (Macromedia Flash) Plug-in voor Mozilla Firefox installeren

sudo apt-get install flashplugin-nonfree
sudo update-flashplugin

Note: if you get an error message that the package is not found, try the Gnash (GNU Flash substitute)

sudo apt-get install libflash-mozplugin
  • Restart Mozilla Firefox

Note: if sound doesn't work in Flash Player (for example op YouTube):

sudo apt-get install alsa-oss
gksudo gedit /etc/firefox/firefoxrc

Change:

FIREFOX_DSP=""

To:

FIREFOX_DSP="aoss"
  • Restart Mozilla Firefox. Now sound should work in Flash Player.

How to update to Flash Player 9 Beta (Macromedia Flash) Plug-in voor Mozilla Firefox

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

wget http://download.macromedia.com/pub/labs/flashplayer9_update/FP9_plugin_beta_101806.tar.gz
tar xvzf FP9_plugin_beta_101806.tar.gz
sudo cp flash-player-plugin-9.0.21.55/libflashplayer.so /usr/lib/flashplugin-nonfree/ 
  • Restart Mozilla Firefox

Hoe kan ik PDF Leeser (Adobe Acrobat Reader) met Plug-in voor Mozilla Firefox installeren

sudo apt-get install acroread mozilla-acroread acroread-plugins
  • Applicaties -> Office -> Adobe Leeser
  • Restart Mozilla Firefox

Note: Adobe Acrobat Reader 7.0 will not run if SCIM is running. You are running SCIM if you have installed another language to Ubuntu via System -> Administration -> Language Support. To circumvent, do the following

gksudo gedit /usr/bin/acroread

Change:

#!/bin/sh
#

to:

#!/bin/sh
#
GTK_IM_MODULE=xim

Save the file. Now Adobe Acrobat Reader 7.0 should work.

See also:

Hoe kan ik Download Manager (Downloader voor X) installeren

sudo apt-get install d4x
  • Applicaties -> Internet -> Downloader voor X


Hoe kan ik een password manager (Revelation) installeren

sudo apt-get install revelation
  • Applicaties -> Accessories -> Revelation Password Manager

Hoe kan ik FTP Client (gFTP) installeren

sudo apt-get install gftp
  • Applicaties -> Internet -> gFTP

Hoe kan ik IRC Client (XChat) installeren

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install xchat xchat-systray 
  • Applicaties -> Internet -> XChat IRC

Hoe kan ik File share utility (LinuxDC++) installeren

wget -c http://easylinux.info/uploads/linuxdcpp.tar.gz
sudo tar zxvf linuxdcpp.tar.gz -C /opt
gksudo gedit /usr/share/applications/linuxdcpp.desktop
  • Voeg de volgende regels toe in het nieuwe bestand
[Desktop Entry]
Encoding=UTF-8
Name=LinuxDC++
Exec=linuxdcpp
Terminal=false
Type=Application
StartupNotify=true
Icon=/opt/linuxdcpp/pixmaps/linuxdcpp.png
Categories=Application;Network;
  • Bewaar het bewerkte bestand
  • Applicaties -> Internet -> LinuxDC++
  • If you whant to build the latest version from CVS use this guide

Hoe kan ik P2P BitTorrent Client (Azureus) installeren

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install azureus
  • Applicaties -> Internet -> Azureus
  • (Alternative Method) The above method installs een version of Azureus compiled met gcj, the free alternative to Sun's Java.
wget http://kent.dl.sourceforge.net/sourceforge/azureus/Azureus_2.5.0.0_linux.tar.bz2
sudo tar jxvf Azureus_2.5.0.0_linux.tar.bz2 -C /opt/
sudo gedit /usr/share/applications/azureus.desktop
  • Add the following to the new file
[Desktop Entry] 
Name=Azureus
Comment=Java BitTorrent Client
Exec=/opt/azureus/azureus
Icon=/opt/azureus/Azureus.png
Terminal=false
Type=Application
Categories=Application;Network;
  • Bewaar het bewerkte bestand
  • Applicaties -> Internet -> Azureus

Hoe kan ik P2P BitTorrent Client (Bittornado) installeren

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install bittornado bittornado-gui
  • Applicaties -> Internet -> Bittornado Client

Hoe kan ik P2P eMule Client (aMule) installeren

Note: Program included in Automatix2 en Easy Ubuntu. I you have already used one of them, this program may have been installed

sudo apt-get install amule
  • Applicaties -> Internet -> aMule

Hoe kan ik P2P Gnutella Client (FrostWire) installeren

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

wget -c http://www.users.on.net/~stubby/FrostWire-4.10.9-2.i586.deb
sudo dpkg -i FrostWire-4.10.9-2.i586.deb
  • Applicaties -> Internet -> FrostWire

Hoe kan ik Messenger (Skype) installeren

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install skype
  • Applicaties -> Internet -> Skype

Hoe kan ik WinPopup (LinPopUp) installeren

sudo apt-get install linpopup
gksudo gedit /usr/share/applications/linpopup.desktop
  • Voeg de volgende regels toe in het nieuwe bestand
[Desktop Entry]
Name=LinPopUp
Comment=LinPopUp
Exec=linpopup
Icon=/usr/share/pixmaps/linpopup.xpm
Terminal=false
Type=Application
Categories=Application;Utility;
  • Bewaar het bewerkte bestand
  • Applicaties -> Accessories -> LinPopUp

Hoe kan ik Multimedia Codecs installeren

sudo apt-get install gstreamer0.10-ffmpeg gstreamer0.10-gl gstreamer0.10-plugins-base \
gstreamer0.10-plugins-good gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse \
gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse w32codecs

Stubby All known codecs work except voor wmv,

Radiobuzzer WMV9 codecs don't work especially voor amd64 users. Advanced users should follow this patch

Hoe kan ik DVD playback capability installeren

ironss: gstreamer dvd plugin is available as part of plugins-bad (or ugly?) en does not work reliably. However, Totem works met the xine backend to play back DVDs. This will keep you going until gstreamer gets dvd playback. Note that you do not have to install xine-ui or mplayer as suggested in

sudo apt-get install libdvdread3 
sudo /usr/share/doc/libdvdread3/install-css.sh
sudo apt-get install totem-xine

Stubby: gstreamer dvd plugin not ported to dapper yet. following instructions will not work properly

sudo apt-get install libdvdcss2

Hoe kan ik Multimedia Player (xine-ui) installeren

sudo apt-get install xine-ui libxine-extracodecs
  • Applicaties -> Sound & Video -> xine

Hoe kan ik Multimedia Player (VLC) met plug-in voor Mozilla Firefox installeren

sudo apt-get install vlc vlc-plugin-* mozilla-plugin-vlc
  • In order to stream video via vlc, you also need to install the following packages.
apt-get install avahi-daemon
apt-get install avahi-utils
Applicaties -> Sound en Video -> VLC Media Player

Hoe kan ik Multimedia Player (Mplayer) met plug-in voor Mozilla Firefox installeren

sudo apt-get install mozilla-mplayer
Applicaties -> Sound en Video -> MPlayer Movie Player

Hoe kan ik Multimedia Player (Totem) met plug-in voor Mozilla Firefox installeren

sudo apt-get install totem-gstreamer-firefox-plugin
  • Restart Mozilla Firefox

Hoe kan ik Multimedia Player (XMMS) installeren

sudo apt-get install xmms xmms-skins
wget -c http://easylinux.info/uploads/xmms-wma_1.0.4-2_i386.deb
sudo dpkg -i xmms-wma_1.0.4-2_i386.deb
  • Applicaties -> Sound & Video -> XMMS

Hoe kan ik Multimedia Player (amaroK) installeren

sudo apt-get install amarok
  • Applicaties -> Sound & Video -> amaroK

Hoe kan ik Multimedia Player (RealPlayer 10) installeren

sudo apt-get install realplay
Note: 'realplay' installs RealPlayer 10 from PLF repository, which you should be enabled if you followed this guide. 'realplayer' installs RealPlayer 8 from multiverse.
  • Applicaties -> Sound & Video -> RealPlayer 10
  • It will also install all the necessary plugins automagically voor it to view embedded real videos in Firefox
  • To avoid issues of flickering or screen going blank when switching windows, goto
  • RealPlayer 10 -> Tools -> Preferences -> Hardware -> Uncheck XVideo


Alternative Source

Hoe kan ik Stream Directory Browser (streamtuner) installeren

sudo apt-get install streamtuner
sudo apt-get install streamripper
  • Applicaties -> Sound & Video -> streamtuner

Hoe kan ik Music Organizer (Cowbell) installeren

sudo apt-get install cowbell
  • Applicaties -> Sound & Video -> Cowbell Music Organizer

Hoe kan ik ID3 Tag Editor (EasyTAG) installeren

sudo apt-get install easytag
  • Applicaties -> Sound & Video -> EasyTAG

Hoe kan ik Video Editor (Kino) installeren

sudo apt-get install kino
sudo apt-get install kinoplus
sudo apt-get install kino-timfx
sudo apt-get install kino-dvtitler
  • Applicaties -> Sound & Video -> Kino Video Editor

Hoe kan ik Audio Editor (Audacity) installeren

sudo apt-get install audacity
  • Applicaties -> Sound & Video -> Audacity

Hoe kan ik Music Manager en Player (Banshee) installeren

sudo apt-get install banshee

Hoe kan ik DVD Ripper (dvd::rip) installeren

sudo apt-get install dvdrip vcdimager cdrdao subtitleripper
sudo ln -fs /usr/bin/rar /usr/bin/rar-2.80
gksudo gedit /usr/share/applications/dvdrip.desktop
  • Voeg de volgende regels toe in het nieuwe bestand
[Desktop Entry]
Name=dvd::rip 
Comment=dvd::rip
Exec=dvdrip
Icon=/usr/share/perl5/Video/DVDRip/icon.xpm
Terminal=false
Type=Application
Categories=Application;AudioVideo;
  • Bewaar het bewerkte bestand
  • Applicaties -> Sound & Video -> dvd::rip

Hoe kan ik DVD Ripper (AcidRip) installeren

sudo apt-get install acidrip


Note: AcidRip will not recognize dvd if dma is turned on. If so undo the process #How to speed up CD/DVD-ROM.

Hoe kan ik CD Ripper (Goobox) installeren

sudo apt-get install goobox
sudo rm -f /usr/share/applications/goobox.desktop
gksudo gedit /usr/share/applications/goobox.desktop
  • Voeg de volgende regels toe in het nieuwe bestand
[Desktop Entry]
Name=CD Player & Ripper
Comment=Play en extract CDs
Exec=goobox
Icon=goobox.png
Terminal=false
Type=Application
Categories=Application;AudioVideo;
  • Bewaar het bewerkte bestand
  • Applicaties -> Sound & Video -> CD Player & Ripper

Hoe kan ik Image Viewer (digiKam) installeren

sudo apt-get install digikam digikamimageplugins kipi-plugins
  • Applicaties -> Graphics -> digikam

Hoe kan ik Picasa image organizer installeren

gksudo gedit /etc/apt/sources.list
  • Add the following lines at the end of file
# Google Picasa voor Linux repository
deb http://dl.google.com/linux/deb/ stable non-free
  • Bewaar het bewerkte bestand
sudo apt-get update
sudo apt-get install picasa
  • Applicaties -> Graphics -> Picasa

Hoe kan ik Internet TV (DemocracyTV beta) installeren

  • If your system has een 32bit processor (i386) open een Terminal en type
wget http://ftp.osuosl.org/pub/pculture.org/democracy/linux/ubuntu/democracyplayer-data_0.9.0.2-1ubuntupcf_all.deb
wget http://ftp.osuosl.org/pub/pculture.org/democracy/linux/ubuntu/democracyplayer_0.9.0.2-1ubuntupcf_i386.deb
sudo apt-get upgrade
sudo dpkg -i democracyplayer-data_0.9.0.2-1ubuntupcf_all.deb
sudo apt-get install mozilla-browser mozilla-psm mozilla-dev
sudo dpkg -i democracyplayer_0.9.0.2-1ubuntupcf_i386.deb


  • if your system has een 64bit processor (amd64)
wget http://ftp.osuosl.org/pub/pculture.org/democracy/linux/ubuntu/democracyplayer-data_0.9.0.2-1ubuntupcf_all.deb
wget http://ftp.osuosl.org/pub/pculture.org/democracy/linux/ubuntu/democracyplayer_0.9.0.2-1ubuntupcf_amd64.deb
sudo apt-get upgrade
sudo dpkg -i democracyplayer-data_0.9.0.2-1ubuntupcf_all.deb
sudo apt-get install mozilla-browser mozilla-psm mozilla-dev
sudo dpkg -i democracyplayer_0.9.0.2-1ubuntupcf_amd64.deb

  • in both cases you might also need to install dependencies of the player package if dpkg returns een dependency error.
sudo apt-get -f install
  • to get support voor more formats you have to install libxine-extracodecs (check Restricted Formats voor more info)
sudo apt-get install libxine-extracodecs

or use an alternate procedure: double klik (or right klik en select "Open met gdebi") op the deb files so they are opened met gdebi, first democracyplayer-data_0.9.0.2-1ubuntupcf_all.deb en after that democracyplayer_0.9.0.2-1ubuntupcf_i386.deb (if you have een 32bit processor) or democracyplayer_0.9.0.2-1ubuntupcf_amd64.deb (if you have een 64bit processor)

  • Applicaties -> Sound & Video -> Democracy TV

Hoe kan ik Vector Graphics Editor (Inkscape) installeren

sudo apt-get install inkscape


Second installation method:

1. Download the official Inkscape Linux installer.
2. Choose een mirror en save it to your Desktop.
3. Right-klik it, enable "Properties --> Permissions --> Owner:Execute" en close the dialogue box. (One-time procedure)
4. Double-klik it en follow the instructions.
5. Install the support code system-wide, if you have the root password. (One-time procedure)

NOTE: You can en should install the program as een User, rather than Root. This is easily accomplished met the second method.

Hoe kan ik Opera web browser installeren

Package may be not found in the repository --Radiobuzzer 22:12, 25 October 2006 (EEST)

sudo apt-get install opera
  • Applicaties -> Internet -> Opera
  • To get java working go to Tools->Preferences->Advanced->Content-> Check "Enable Java". Click the "Enable Java..." button enter "/usr/lib/jvm/java-1.5.0-sun/jre/lib/i386" (for sun java) in the new dialog en then klik the "Validate Java Path" button.

Hoe kan ik Email Client (Mozilla Thunderbird) installeren

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install mozilla-thunderbird
  • Applicaties -> Internet -> Thunderbird Mail Client

Hoe kan ik Newsreader (Pan) installeren

sudo apt-get install pan
  • Applicaties -> Internet -> Pan Newsreader

Hoe kan ik RSS/RDF/Atom Newsreader (RSSOwl) installeren

wget -c http://easylinux.info/uploads/rssowl_linux_1_1_3_bin.tar.gz
sudo tar zxvf rssowl_linux_1_1_3_bin.tar.gz -C /opt/
sudo chown -R root:root /opt/rssowl_linux_1_1_3_bin/
gksudo gedit /usr/bin/runRSSOwl.sh
  • Voeg de volgende regels toe in het nieuwe bestand
export MOZILLA_FIVE_HOME=/usr/lib/mozilla-firefox
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:${MOZILLA_FIVE_HOME}:${LD_LIBRARY_PATH}
cd /opt/rssowl_linux_1_1_3_bin/
./run.sh
  • Bewaar het bewerkte bestand
sudo chmod +x /usr/bin/runRSSOwl.sh
gksudo gedit /usr/share/applications/RSSOwl.desktop
  • Voeg de volgende regels toe in het nieuwe bestand
[Desktop Entry]
Name=RSSOwl
Comment=RSSOwl
Exec=runRSSOwl.sh
Icon=/opt/rssowl_linux_1_1_3_bin/rssowl.xpm
Terminal=false
Type=Application
Categories=Application;Network;
  • Bewaar het bewerkte bestand
  • Applicaties -> Internet -> RSSOwl

Hoe kan ik Web Authoring System (Nvu) installeren

sudo apt-get install nvu
sudo rm -f /usr/share/applications/nvu.desktop
gksudo gedit /usr/share/applications/nvu.desktop
  • Voeg de volgende regels toe in het nieuwe bestand
[Desktop Entry]
Name=Nvu
Comment=Web Development Editor
Exec=nvu
Icon=nvu.xpm
Terminal=false
Type=Application
Categories=Application;Development;
  • Bewaar het bewerkte bestand
  • Applicaties -> Internet -> Nvu

Hoe kan ik Web Development Environment (quanta plus) installeren

sudo apt-get install quanta
  • Applicaties -> Programming -> Quanta Plus

Hoe kan ik Project Management Application (Planner) installeren

sudo apt-get install planner
  • Applicaties -> Office -> Project Management


Hoe kan ik jedit installeren

wget -c http://optusnet.dl.sourceforge.net/sourceforge/jedit/jedit_4.3pre6_all.deb
sudo dpkg -i jedit_4.3pre6_all.deb
  • Applicaties -> Programming -> Programmers text editor jedit
Note: Install jedit op Dapper Drake might cause broken package which leads to Synaptic Package Manager fails to function. To remove see #How to remove jedit when Synaptic package manager fails after install.

Hoe kan ik Accounting Application (GnuCash) installeren

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install gnucash
sudo rm -fr /usr/share/gnome/apps/Applicaties/
gksudo gedit /usr/share/applications/GnuCash.desktop
  • Voeg de volgende regels toe in het nieuwe bestand
[Desktop Entry]
Name=GnuCash
Comment=GnuCash Personal Finance
Exec=gnucash
Icon=/usr/share/pixmaps/gnucash/gnucash-icon.png
Terminal=false
Type=Application
Categories=Application;Office;
  • Bewaar het bewerkte bestand
  • Applicaties -> Office -> GnuCash

Hoe kan ik Desktop Publishing Application (Scribus) installeren

sudo apt-get install scribus
  • Applicaties -> Office -> Scribus

Hoe kan ik Diagram Editor (Dia) installeren

sudo apt-get install dia-gnome
  • Applicaties -> Graphics -> Dia

Hoe kan ik Compiled HTML Help (CHM) Viewer (xCHM) installeren

sudo apt-get install xchm
  • Applicaties -> Graphics -> xCHM

Hoe kan ik CD/DVD Burning Application (GnomeBaker) installeren

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install gnomebaker
  • Applicaties -> Sound & Video -> GnomeBaker

Hoe kan ik CD/DVD Burning Application (K3b) installeren

sudo apt-get install k3b libk3b2-mp3
  • Applicaties -> Sound & Video -> K3b

Hoe kan ik Dialup PPP Client (GNOME PPP) installeren

sudo apt-get install gnome-ppp
  • Applicaties -> Internet -> GNOME PPP

Hoe kan ik Broadband ADSL/PPPoE Client (RP-PPPoE) installeren

wget -c http://easylinux.info/uploads/rp-pppoe-3.6.tar.gz
sudo tar zxvf rp-pppoe-3.6.tar.gz -C /opt/
sudo chown -R root:root /opt/rp-pppoe-3.6/
gksudo gedit /usr/share/applications/RP-PPPoE.desktop
  • Voeg de volgende regels toe in het nieuwe bestand
[Desktop Entry]
Name=RP-PPPoE
Comment=RP-PPPoE
Exec=gksudo /opt/rp-pppoe-3.6/go-gui
Icon=pppoeconf.xpm
Terminal=false
Type=Application
Categories=Application;Network;
  • Bewaar het bewerkte bestand
  • Applicaties -> Internet -> RP-PPPoE

Hoe kan ik Boot-Up Manager (BUM) installeren

sudo apt-get install bum
  • System -> Administration -> Boot-Up Manager

Hoe kan ik Partition Editor (GParted) installeren

sudo apt-get install gparted
  • Applicaties -> System Tools -> GParted

Hoe kan ik Firewall (Firestarter) installeren

sudo apt-get install firestarter
  • Applicaties -> System Tools -> Firestarter

Hoe kan ik network traffic analyzer (Ethereal) installeren

sudo apt-get install ethereal
  • Applicaties -> Internet -> Ethereal

Hoe kan ik Vulnerability Scanner (Nessus) installeren

sudo apt-get install nessus
sudo apt-get install nessusd
sudo nessus-adduser
sudo ln -fs /etc/init.d/nessusd /etc/rc2.d/S20nessusd
sudo /etc/init.d/nessusd start
gksudo gedit /usr/share/applications/Nessus.desktop
  • Voeg de volgende regels toe in het nieuwe bestand
[Desktop Entry]
Name=Nessus
Comment=Nessus
Exec=nessus
Icon=/usr/share/pixmaps/nessus.xpm
Terminal=false
Type=Application
Categories=Application;System;
  • Bewaar het bewerkte bestand
  • Applicaties -> System Tools -> Nessus

Hoe kan ik RAR Archiver (rar) installeren

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install rar 
sudo apt-get install unrar
  • Applicaties -> Accessories -> Archive Manager

Hoe kan ik Extra Fonts installeren

sudo apt-get install xfonts-intl-arabic
sudo apt-get install xfonts-intl-asian
sudo apt-get install xfonts-intl-chinese
sudo apt-get install xfonts-intl-chinese-big
sudo apt-get install xfonts-intl-european
sudo apt-get install xfonts-intl-japanese
sudo apt-get install xfonts-intl-japanese-big
sudo apt-get install xfonts-intl-phonetic
sudo apt-get install gsfonts-x11
sudo apt-get install msttcorefonts
sudo fc-cache -f -v


Note: Ubuntu Dapper comes met the DejaVu fonts (derived from Bitstream Vera) en provides adequate support voor Latin, Greek en Cyrillic based languages.

Hoe kan ik Chinese Input Method (SCIM) installeren

The following advices are outdated en it could be hard to revert to normal afterwards. Please follow instead the official Ubuntu 6.06 Dapper Drake guide HERE

Please note that scim is now installed by default in Dapper, en installing Chinese, Japanese or Korean Support is done using System>Administration>Language Support. The wiki details the method more thoroughly

sudo apt-get install scim
sudo apt-get install scim-chinese
sudo apt-get install scim-config-socket
sudo apt-get install scim-gtk2-immodule
sudo apt-get install scim-tables-zh
wget -c http://easylinux.info/uploads/fireflysung-1.3.0.tar.gz
sudo tar zxvf fireflysung-1.3.0.tar.gz -C /usr/share/fonts/truetype/
sudo chown -R root:root /usr/share/fonts/truetype/fireflysung-1.3.0/ 
sudo fc-cache -f -v
  • System -> Preferences -> SCIM Input Method Setup
  • To activate SCIM
Press 'Ctrl + Space'

Hoe kan ik Desktop Applets (gDesklets) installeren

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install gdesklets
sudo apt-get install gdesklets-data

Hoe kan ik Basic Compilers (build-essential) installeren

sudo apt-get install build-essential

Hoe kan ik .rpm to .deb Converter (Alien) installeren

sudo apt-get install alien

Hoe kan ik Integrated Development Environment (Anjuta) installeren

sudo apt-get install anjuta
  • Applicaties -> Programming -> Anjuta IDE

Hoe kan ik C# Integrated Development Environment (MonoDevelop) installeren

sudo apt-get install mono mono-gmcs mono-gac mono-utils monodevelop

Hoe kan ik Java Integrated Development Environment (Eclipse) installeren

sudo apt-get install eclipse
  • Applicaties -> Development -> Eclipse

Hoe kan ik 3D modeling tool (Blender 3d) installeren

sudo apt-get install blender
  • Applicaties -> Graphics -> Blender 3D modeller

Hoe kan ik game Tuxracer installeren

sudo apt-get install planetpenguin-racer planetpenguin-racer-data planetpenguin-racer-extras
  • Applicaties -> Games -> planetpenguin-racer

Hoe kan ik game Frozen-Bubble installeren

sudo apt-get install frozen-bubble
  • Applicaties -> Games -> Frozen-Bubble

Hoe kan ik game Scorched3D installeren

sudo apt-get install scorched3d
gksudo gedit /usr/share/applications/scorched3d.desktop
  • Voeg de volgende regels toe in het nieuwe bestand
[Desktop Entry]
Name=Scorched 3D
Comment=A 3D Remake Of Scorched Earth
Exec=scorched3d
Icon=
Terminal=false
Type=Application
Categories=Application;Game;ArcadeGame;
  • Bewaar het bewerkte bestand
  • Applicaties -> Games -> Scorched 3D

Hoe kan ik real-time-strategy game (globulation 2 alpha21) installeren

wget http://globulation2.org/releases/0.8.21/glob2_alpha21_i386.deb
sudo dpkg -i glob2_alpha21_i386.deb

you might also need to install dependencies if dpkg returns een dependency error

sudo apt-get -f install

to play use command

glob2

Hoe kan ik virtual planetarium (Stellarium) installeren

sudo apt-get install stellarium
gksudo gedit /usr/share/applications/stellarium.desktop
  • Voeg de volgende regels toe in het nieuwe bestand
[Desktop Entry]
Name=Stellarium
Comment=Virtual planetarium
Exec=stellarium
Terminal=false
Type=Application
Categories=Application;Education;
Icon=stellarium
  • Applicaties -> Education -> Stellarium

Second installation method: (version 0.6.2)

1. Download the Stellarium Linux installer.
2. Save it to your Desktop.
3. Right-klik it, enable "Properties --> Permissions --> Owner:Execute" en close the dialogue box. (One-time procedure)
4. Double-klik it en follow the instructions.
5. Install the support code system-wide, if you have the root password. (One-time procedure)

NOTE: You can en should install the program as een User, rather than Root. This is easily accomplished met the second method.

Hoe kan ik Google Toolbar voor Firefox installeren

The current version of Google Toolbar works fine met Firefox 1.5.0.5 in Ubuntu 6.06

In Firefox, klik the link below

http://www.google.com/tools/firefox/toolbar/

then klik op the big download button.

Hoe kan ik Google Earth installeren

wget -c http://dl.google.com/earth/GE4/GoogleEarthLinux.bin
sudo sh GoogleEarthLinux.bin
  • Leave /usr/local/google-earth as the installation path
  • After installation klik Exit. If you instead chose to run the application, read the Note below.
sudo cp /usr/local/google-earth/googleearth.desktop /usr/share/applications/
  • Applicaties -> Internet -> Google Earth
  • Note: If you run Google Earth voor the first time from the installer, it will require root privileges to run the next time. To fix that:
sudo chmod 777 -R ~/.googleearth

Hoe kan ik KDE Edutainment applications installeren

sudo apt-get install kdeedu
  • Applicaties -> Education -> ...

Hoe kan ik Internet Explorer + Flash 9 installeren

This will install een wine'd version of Internet Explorer 6 met Flash 9, as well as IE 5.5/5.01 if you really want them.

  • Note: This installed Flash 9 will NOT be available in browsers other than IE.
  • Install Cabextract. Open een terminal en run
sudo apt-get install cabextract
  • Open een terminal en run this:
wget http://www.tatanka.com.br/ies4linux/downloads/ies4linux-2.0.tar.gz -O - | tar xvzf -
  • Or, if that doesn't work, use this command:
wget http://modzer0.cs.uaf.edu/~hardwarehank/files/ies4linux-2.0.tar.gz -O - | tar xvzf -
  • Then, just run it:
cd ies4linux-2.0
sh ies4linux

You don't have to run it as root (no sudo). If you do, it will make global symlinks, which is fine if you want that. Otherwise, it will use ~/bin. Lees the README:

less README

Hoe kan ik Windows Applicaties in Linux (Wine) installeren

Wine Is Not an Emulator. Wine is an Open Source implementation of the Windows API op top of X en Unix. Think of Wine as een compatibility layer voor running Windows programs. Wine does not require Microsoft Windows, as it is een completely free alternative implementation of the Windows API consisting of 100% non-Microsoft code, however Wine can optionally use native Windows DLLs if they are available.

In other words, Wine will let you run Windows applications in Linux.

  • First, add repository voor Wine:
gksudo gedit /etc/apt/sources.list
  • Voeg de volgende regels toe aan het einde van dit bestand
# Repository voor wine
deb http://wine.budgetdedicated.com/apt dapper main
deb-src http://wine.budgetdedicated.com/apt dapper main
  • Bewaar het bewerkte bestand
sudo apt-get update
sudo apt-get install wine

Hoe kan ik een Drop Down Terminal like in First Person Shooters (tilda) installeren

Do you want een console like in een first person shooter? Tilda should take care of you.

sudo apt-get install tilda
  • The default keybinding is F1. To change the default keybinding, either enter tilda -C at the terminal, or right klik op the tilda terminal then klik Preferences. While in preferences, you can change other things such as transparency, font, size, en window size.

Ubuntu:EdgyNL/AndereDesktopOmgevingen

Eye Candy

Hoe kan ik Xgl/Compiz (Nvidia) installeren



sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup
gksudo gedit /etc/X11/xorg.conf
  • Find this section
Section "Module"
	Load	"i2c"
	Load	"bitmap"
	...
	Load	"type1"
	Load	"vbe"
EndSection
  • Comment out dri en GLcore (if present)
#	Load	"dri"
#	Load	"GLcore"
  • Make sure the glx module is loaded
	Load	"glx"
  • Find this section (your values may vary)
Section "Device"
	Identifier	"NVIDIA Corporation NV34M [GeForce FX Go5200]"
	Driver		"nv"
	BusID		"PCI:1:0:0"
EndSection
  • Replace met the following lines, leaving the Identifier en BusID as it is
Section "Device"
	...
	Driver		"nvidia"
	...
	Option		"RenderAccel"		"true"
	Option		"AllowGLXWithComposite" "true"
EndSection
  • Find this section
Section "Screen"
	Identifier	"Default Screen"
	Device		"NVIDIA Corporation NV34M [GeForce FX Go5200]"
	Monitor		"Generic Monitor"
	DefaultDepth	16
  • Make sure DefaultDepth is set to 24, if it isn't already
	DefaultDepth	24
  • Bewaar het bewerkte bestand
  • Install Xgl/Compiz
sudo apt-get install compiz xserver-xgl libgl1-mesa xserver-xorg libglitz-glx1 compiz-gnome
sudo cp /etc/gdm/gdm.conf-custom /etc/gdm/gdm.conf-custom-backup
gksudo gedit /etc/gdm/gdm.conf-custom
  • Replace everything met the following lines
# GDM Configuration Customization file.
#
# This file is the appropriate place voor specifying your customizations to the
# GDM configuration.   If you run gdmsetup, it will automatically edit this
# file voor you en will cause the daemon en any running GDM GUI programs to
# automatically update met the new configuration.  Not all configuration
# options are supported by gdmsetup, so to modify some values it may be
# necessary to modify this file directly by hand.
# 
# To hand-edit this file, simply add or modify the key=value combination in
# the appropriate section in the template below.  Refer to the comments in the
# gdm.conf file voor information about each option.  Also refer to the reference
# documentation.
# 
# If you hand edit een GDM configuration file, you should run the following
# command to get the GDM daemon to notice the change.  Any running GDM GUI
# programs will also be notified to update met the new configuration.
#
# gdmflexiserver --command="UPDATE_CONFIG <configuration key="key">"
#
# For example, the "Enable" key in the "[debug]" section would be specified by
# "debug/Enable".
#
# You can also run gdm-restart or gdm-safe-restart to cause GDM to restart and
# re-read the new configuration settings.  You can also restart GDM by sending
# een HUP or USR1 signal to the daemon.  HUP behaves like gdm-restart en causes
# any user session started by GDM to exit immediately while USR1 behaves like
# gdm-safe-restart en will wait until all users log out before restarting GDM.
# 
# For full reference documentation see the gnome help browser under
# GNOME|System category.  You can also find the docs in HTML form on
# http://www.gnome.org/projects/gdm/
# 
# NOTE: Lines that begin met "#" are considered comments.
# 
# Have fun!

[daemon]

[security]

[xdmcp]

[gui]

[greeter]

[chooser]

[debug]

[servers]# Override display 1 to use Xgl
0=Xgl 

[server-Xgl] 
name=Xgl server 
command=/usr/bin/Xgl :0 -fullscreen -ac -accel glx:pbuffer -accel xv:fbo 
flexible=true
  • Create een script that runs Xgl/Compiz op startup
gksudo gedit /usr/bin/thefuture
  • Voeg de volgende regels toe in het nieuwe bestand. Replace .us met appropriate keyboard binding voor your region. Eg .gb voor United Kingdom. For een full list of keyboard bindings, type ls /usr/share/xmodmap in een terminal. If unsure, leave as .us (United States)
#!/bin/bash
gnome-window-decorator &  compiz --replace gconf decoration wobbly fade minimize cube rotate zoom scale move resize place switcher &
xmodmap /usr/share/xmodmap/xmodmap.us
  • Save the file
sudo chmod 755 /usr/bin/thefuture
  • To run compiz voor this session
thefuture
  • To have compiz load op startup
    • System -> Preferences -> Sessions
    • Startup Programs -> Add
/usr/bin/thefuture
  • Probleemoplossen
    • If Xgl/Compiz doesn't seem to work, or you get errors, simply restart your machine after adding "thefuture" to Startup programs
    • If moving windows slows down the system, run gconf-editor from the terminal. Find apps/compiz/general/screen0/options. Disable detect_refresh_rate en set refresh rate to 60. Everything should work fine now...
    • If you are using een non default keyboard layout (other language), you might have to change it back to what you need if the keyboard acts funny at System/Settings/Keyboard.
    • You can also set the Super-key to the windows button here.
    • If you don't want "bottom expanded panel", type "killall gnome-panel" in terminal.
  • Tips
    • Switch windows = Alt + Tab
    • Arrange en View All Windows = F12 turns op or off; kliking een window will zoom it to the front
    • Switch desktops op cube = Ctrl + Alt + Left/Right Arrow
    • Switch desktops op cube - met active window following = Ctrl + Shift + Alt + Left/Right Arrow
    • Rotate cube manually = Ctrl + Alt + left-klik
    • Make window translucent/opaque = currently only possible met the "transset" utility
    • Zoom-in once = Super-key right-klik
    • Zoom-in manually = Super-key + wheel mouse up
    • Zoom-out manually = Super-key + wheel mouse down
    • Move window = Alt + left-klik
    • Snap Move window (will stick to borders) = Ctrl + Alt + left-klik
    • Resize window = Alt + right-klik

Hoe kan ik Xgl/Beryl (ATI) installeren

(From Beryl Forums)

First make sure you have 3d acceleration available in een normal gnome session. There are lots of howtos voor this , Google if you need any help met that. So if glxinfo shows direct rendering: yes , then you are good to go. If not xgl en Beryl wont work!

  • Update your system
sudo apt-get update
sudo apt-get dist-upgrade
  • Prepare en update repositories
sudo gedit /etc/apt/sources.list
  • Add quinstorms' en reggaemanus' repositories to /etc/apt/sources.list
deb http://www.beerorkid.com/compiz/ dapper main
deb http://xgl.compiz.info/ dapper main
deb-src http://xgl.compiz.info/ dapper main
  • Download en import the gpg key voor quinnstorms repository
 wget http://www.beerorkid.com/compiz/quinn.key.asc -O - | sudo apt-key add -
  • Update your sources
sudo apt-get update
  • Install needed packages
sudo apt-get install xserver-xgl libgl1-mesa xserver-xorg libglitz-glx1 beryl beryl-core beryl-manager beryl-plugins beryl-plugins-data beryl-settings emerald emerald-themes
  • Make een startup script voor xgl
sudo gedit /usr/bin/startxgl.sh
  • Add to script
Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:pbuffer & sleep 2 && DISPLAY=:1 
# Start GNOME
exec gnome-session
  • Make the script executable
sudo chmod 755 /usr/bin/startxgl.sh
  • Make een xgl session voor the login manager
sudo gedit /usr/share/xsessions/xgl.desktop
  • Add to session
[Desktop Entry]
Encoding=UTF-8
Name=XGl
Exec=/usr/bin/startxgl.sh
Icon=
Type=Application
  • add
beryl
emerald

to gnome session startup programs. ( go to system , preferences , sessions en select the startup programs tab )

  • Reboot
  • In the login manager you can now choose een session named Xgl
  • Answer to following question that you want to use Xgl voor this session only (if something went wrong you are logged in next time using standard session)
  • If everything works fine , you can set it as the default session , remember you can always login een normal gnome session if you want.
  • If you own an x series radeon en have problems met lockups, read this post:

http://ubuntuforums.org/showthread.php?t=150854

Note voor all cards: glxinfo will show that direct rendering is not working , dont worry thats normal when you are running xgl.

Hoe kan ik Beryl/AIGLX (Nvidia) installeren

(From Ubuntu Forums)

  • Ensure all packages up to date
Install your *ubuntu-desktop metapackage specific to your DE, e.g. sudo apt-get install ubuntu-desktop
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
  • Add repositories
gksudo gedit /etc/apt/sources.list
  • Voeg de volgende regels toe aan het einde van dit bestand:
deb http://dev.realistanew.com/beryl edgy beryl
deb http://beryl-mirror.lupine.me.uk/beryl edgy beryl

(If you need the 64bit beryl add this to the repository list)

deb http://ubuntu.lupine.me.uk/ edgy main-amd64
  • Bewaar het bewerkte bestand
sudo apt-get update
  • Install Beryl
sudo apt-get install beryl-core beryl-plugins beryl-plugins-data emerald beryl-settings beryl-manager beryl beryl-dev emerald-themes
  • Back up xorg.conf
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup
gksudo gedit /etc/X11/xorg.conf
  • Add this to xorg.conf "Screen" section
# Enable 32-bit ARGB GLX Visuals
    Option "AddARGBGLXVisuals" "True"

# If you are using an older version of compiz that
# does not support rendering into the Composite
# Overlay Window, you will need to disable clipping
# of GLX rendering to the X Root window met this
# option, or you will get een blank screen after
# starting compiz:
    Option "DisableGLXRootClipping" "True"
  • Add this to xorg.conf "Device" section
Option          "TripleBuffer" "true"
  • Restart X met ctrl+alt+backspace
  • Start Beryl
beryl-start

or

beryl-manager

Hoe kan ik alternate boot splash screen installeren

  • Lees #Algemene Opmerkingen
  • This installs een minimalistic splash screen that appears when the computer is booting up en shutting down. It is devoid of any text messages.
wget -c http://www.users.on.net/~stubby/usplash-minimalistic_0.1.deb
sudo dpkg -i usplash-minimalistic_0.1.deb
sudo update-alternatives --config usplash-artwork.so
  • Select the minimalistic alternative (/usr/local/lib/usplash/minimalastic.so) by entering the corresponding number. If you ever want to revert back to the original splash, select the default (/usr/lib/usplash/usplash-default.so)

Ubuntu:EdgyNL/CommericieleApplicaties

User Administration

How to set/change/enable root user password

sudo passwd root

How to disable root user account

sudo passwd -l root

How to allow root user to login into GNOME

Security Tab -> Security -> Allow root to login with GDM (Checked)

How to switch to root user in Console mode

sudo -s -H
Password: <specify user password>

or

sudo su
Password: <specify user password>

How to add/edit/delete system users

  • Read #General Notes
  • System -> Administration -> Users and Groups
  • Users and Groups
Users Tab -> Add User.../Properties/Delete
or
sudo useradd jim
sudo userdel jim
  • For more info read
man usermod

How to add/edit/delete system groups

  • Read #General Notes
  • System -> Administration -> Users and Groups
  • Users and Groups
Groups Tab -> Add Group.../Properties/Delete

How to automatic login into GNOME (not secure)

Security Tab -> Enable Automatic Login (Checked)
Now choose a user from the drop-down menu.

How to allow more sudoers

EDITOR=gedit sudo visudo
  • Append the following line at the end of file
system_username	ALL=(ALL) ALL
  • Save the edited file

OR since everyone in the admin group can use sudo:

sudo adduser a_username admin

This appends the admin group to the user's supplementary group list. They will now have sudo access.

How to use "sudo" without prompt for password (not secure)

EDITOR=gedit sudo visudo
  • Find this line
...
system_username	ALL=(ALL) ALL
...
  • Replace with the following line
system_username	ALL=(ALL) NOPASSWD: ALL
  • Save the edited file

How to explicitly destroy the "sudo" session

sudo -K

How to change files/folders permissions

Right click on files/folders -> Properties
Permissions Tab -> Read/Write/Execute (Checked the permissions for Owner/Group/Others)

How to change files/folders ownership

sudo chown system_username /location_of_files_or_folders

How to change files/folders group ownership

sudo chgrp system_groupname /location_of_files_or_folders

Ubuntu:EdgyNL/Hardware

Ubuntu:EdgyNL/CDDVDBranden

Ubuntu:EdgyNL/Netwerken

Ubuntu:EdgyNL/InloggenOpAfstand

Ubuntu:EdgyNL/Windows

Ubuntu:EdgyNL/Beveiliging

Ubuntu:EdgyNL/BootMenu

Ubuntu:EdgyNL/TipsEnTruuks

Ubuntu:EdgyNL/Servers

Ubuntu:EdgyNL/Probleemoplossen

Ubuntu:EdgyNL/UbuntuUpgraden

Personal tools
Sponsor
   CuBox